Feathers 1.1.1

You may have spotted Gamua’s release of Starling Framework 1.4 the other day. If not, go check it out right now! The new version of Starling contains some great performance improvements, better context loss handling and customization, and many more nice, new features. After you’ve checked out the new version of Starling, be sure to upgrade to the new Feathers 1.1.1 too!

Feathers 1.1.1 focuses mainly on maintaining compatibility with the current stable version of Starling. Some APIs in Starling changed a bit, so Feathers needed a few modifications here and there to compile correctly. Additionally, I slipped in a number of minor bug fixes that were originally on track for the Feathers 1.2 release. No new components or exciting new features. This is purely a maintenance release. Stay tuned for the beta version of Feathers 1.2 later this year. The full details of what’s changed in Feathers 1.1.1 can be found in the release notes. Happy coding!

About Josh Tynjala

Josh Tynjala is a frontend software developer, open source contributor, karaoke enthusiast, and he likes bowler hats. Josh develops Feathers UI, a user interface component library for creative apps. He also built Logic.ly, a digital logic circuit simulator for education. You should follow Josh on Twitter.

Discussion

  1. Loc Luu

    Hi Josh,
    I’m using Feathers 1.2 in FlashDevelop, when I create some components like button, the FD cannot show code suggestion of object properties like x, y…
    Is it problem of FD or Feathers?
    I have used previous version Feathers before and dont see this problems.

    1. Josh Tynjala

      I test the Feathers SWC with every release using Flash Builder 4.7, and everything has been working fine for me. If it’s not providing code hinting, that’s probably a FlashDevelop issue.

Leave a Reply

Your email address will not be published. Required fields are marked *